EC2のApacheとPHPのバージョンって古くね?

php-med-trans

AWS(EC2)にWordPressをインストールしてみるの続き。
WordPressにプラグインインストールしていったら、
テスト環境では動いていたプラグイン「Add From Server」がEC2の環境では動かない。
何でかなーと思ったら、PHP5.4以上じゃなきゃだめなんだとか。
あれ、じゃ今のEC2のPHPのバージョンってなんだろ?と調べたところ・・・

$ php --version
PHP 5.3.29 (cli) (built: May 12 2015 22:42:19)

あれ、5.3か。じゃ、phpをインストールしなおすかな。
なお、最新(2016/1/31現在)のPHP5.6を使うには、Apacheも2.4以上を入れないといけないっぽぃ。

と、言うわけでここら辺を参考に再インストール。
EC2で古いPHPをアンインストールし、PHP5.4をインストールする
AWS EC2 で始めるお手軽LAMP環境 APACHE2.4 MYSQL5.5 PHP5.6

ここまでやったところで、httpdが起動しなくなった。
たぶん、Redmine動かしているあたりの設定がおかしくなったっぽい。
バックアップからもどしてもいいけど、この際だから作り直すか。

今週は時間がないので、ここまで。


この投稿へのコメント

コメントはありません。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

この投稿へのトラックバック

トラックバックはありません。

トラックバック URL